Jump to content
Steve Shears

Power door Issues

Recommended Posts

Morning All,

Great Forum. I wonder if anyone else has has issues with their power doors?

My problem is that they both work fine on Key fob and dash button but they are really tempremental on the handle activation, they may work 3 or 4 out of 10 times.

Could it  be some relay somewhere  that needs cleaning ?

 

I am worried that this is getting worse and that they will eventually stop.

 

Model is a Gen 1 Alphard 3.0 2003

 

Many thanks in advance 

 

Steve

 

Share this post


Link to post
Share on other sites

Hi Steve,

 

Not personally got these doors/ :( though on my estima (before the alphard) we had issues with the contacts in the door switches for the automatic motor. I stripped them down and used some fine sandpaper on the contacts as they just got gunged up with crap.

 

Might be worth doing some tlc to the contacts of the handles.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.