Jump to content

Heater pipe


Recommended Posts

My alphard 3.0 broke down over the weekend a plastic t piece connector from the heater matrix snapped leaking coolant everywhere has this happened to anyone else .I just want to know if anyone else had same problem and how easy is it to fix 

Link to comment
Share on other sites

Had this happen on my older Regius.

It was during lockdown, so never bothered fixing it, I just bypassed it and drove without any heating, but it should be a simple case of replacing and refilling coolant

Link to comment
Share on other sites

Thank you Chris rac came out they said they could had fixed it but they did not have a t piece so I guess if they could do it must be simple to do .

Link to comment
Share on other sites

yeah, i was going to use a regular copper plumbing t piece, the parts are common enough, so direct through toyota dealer may be your best bet, otherwise online.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.