Jump to content

Speedometer Fault


Recommended Posts

Hi there,

I bought my 2008 Hybrid alphard a couple of months ago and in the last few weeks the speedometer has developed a fault.  It takes a while for the speedo to "turn on", I'll be driving and sometimes it can be a mile before it turns on.  Once it does it seems to work ok.  Has anyone had this fault before and if so what was the caus and fix?

Thanks, Jason

Link to comment
Share on other sites

10 minutes ago, Jay Hine said:

Hi there,

I bought my 2008 Hybrid alphard a couple of months ago and in the last few weeks the speedometer has developed a fault.  It takes a while for the speedo to "turn on", I'll be driving and sometimes it can be a mile before it turns on.  Once it does it seems to work ok.  Has anyone had this fault before and if so what was the caus and fix?

Thanks, Jason

 

Hello Jason,

 

Welcome to the Forum.

Link to comment
Share on other sites

It's the speedo chip behind the clock this is fitted by the dealer to convert kph to mph the chip used is called a ckun09 I would say the chip not at fault but the installation of it they are supposed to be soldered in but lots of fitters use wire connections which is no good .

Link to comment
Share on other sites

  • 2 months later...

Hi Jay

Did you get a resolution to your speedo fault. I have a similar issue where the speedo stops working sometimes.

I would be extremely interested in whether you solved the problem and whether you could give ne some advice.

Mark

Link to comment
Share on other sites

5 hours ago, Mark Stewart said:

Hi Jay

Did you get a resolution to your speedo fault. I have a similar issue where the speedo stops working sometimes.

I would be extremely interested in whether you solved the problem and whether you could give ne some advice.

Mark

 

I had this problem while test driving.

 

Apparently it was caused by the loose chip earth wire.

Link to comment
Share on other sites

  • 2 months later...

Hi, if it’s any help I removed my block connectors and soldered mine behind the dash after engine light came on and the Speedo needle was acting erratically. Easy to get to behind dash and alter.

yet to test speedo but engine light is out.

B98098DC-E86C-46F9-A0F4-6C445D018AE7.jpeg

  • Like 1
Link to comment
Share on other sites

We’ll after having thought I’d fixed my erratic speedo needle (wouldn’t go past 20kmh and jumping) and the engine light coming on - I was wrong.

Had soldered all joints to the converter unit including the earth connector but in the end went with the advice to remove the converter and all now working as it should.

Will probably go for the mph dial face instead.

So I hope this tale adds to helping anyone in the future.🤨

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.