Jump to content

Heater has started blowing cold air


Recommended Posts

Hi can anyone help my alphard 3.0 has started blowing cold air from heaters I have just got a lpg conversion done few days ago yesterday I put heating on and it's only blowing cold air out Temp is going up on dash any body no  what it could be 

Link to comment
Share on other sites

30 minutes ago, Mohammed imran said:

Hi can anyone help my alphard 3.0 has started blowing cold air from heaters I have just got a lpg conversion done few days ago yesterday I put heating on and it's only blowing cold air out Temp is going up on dash any body no  what it could be 

Can you please share where the lpg conversion was done? What is name of the kit? Brand / kit.

Link to comment
Share on other sites

10 hours ago, Mohammed imran said:

Hi can anyone help my alphard 3.0 has started blowing cold air from heaters I have just got a lpg conversion done few days ago yesterday I put heating on and it's only blowing cold air out Temp is going up on dash any body no  what it could be 

 

Hello Mohammed,

 

Welcome to the Forum,

 

Someone else had a similar problem; I'll try to find it.

 

Are you sure you have the air con turned off ?

What temp is going up ?

The water temp; to a level much higher than usual ?

Link to comment
Share on other sites

14 hours ago, Mohammed imran said:

Hi can anyone help my alphard 3.0 has started blowing cold air from heaters I have just got a lpg conversion done few days ago yesterday I put heating on and it's only blowing cold air out Temp is going up on dash any body no  what it could be 

 

Sounds like you have air the the system and needs bleeding.

Link to comment
Share on other sites

20 minutes ago, Mohammed imran said:

Hi temperature is just under half way and stays there it is a stag lpg system 

Guy in wales I've been hearing is stag expert (15 years?). Andrew 01443 812893. Try calling him, unless he is the one who fitted it!

Link to comment
Share on other sites

6 hours ago, Mohammed imran said:

Hi temperature is just under half way and stays there it is a stag lpg system 

 

it really sounds like you have air in the Matrix. Thats why the temprature is half way because the water is still circulating but the air is trapped behind the dash. 

 

do the following

 

  1. let car go cold
  2. turn on engine
  3. whack temperature to hot .. full heat on the dash
  4. open up coolant cap on rad and bottle (do this when cold!!!)
  5. let the engine run to its temperature
  6. top up with coolant as needed as the engine will burp itself and the air will displace and will need a top up
  7. once the level stops dropping, top up and put cap on. Remember to do this part.

 

Very important you open up the heating on both front and back control panels this will allow the water to flow around both front and rear matrix.

Link to comment
Share on other sites

56 minutes ago, Alphard Club said:

 

it really sounds like you have air in the Matrix. Thats why the temprature is half way because the water is still circulating but the air is trapped behind the dash. 

 

do the following

 

  1. let car go cold
  2. turn on engine
  3. whack temperature to hot .. full heat on the dash
  4. open up coolant cap on rad and bottle (do this when cold!!!)
  5. let the engine run to its temperature
  6. top up with coolant as needed as the engine will burp itself and the air will displace and will need a top up

 

Very important you open up the heating on both front and back control panels this will allow the water to flow around both front and rear matrix.

 

Is this a guide ?

Link to comment
Share on other sites

2 hours ago, Mohammed imran said:

Thanks I will try this 

 

@Mohammed imran

one point is that when it comes to boiling then you should add the cap back on or sooner.. you cannot leave cap off all the time, until you feel heat then you should be fine and its stopped burping itself. Just be careful.

Link to comment
Share on other sites

  • 2 weeks later...
On 6/20/2022 at 9:35 AM, Rojie said:

 

Hello Mohammed,

 

Welcome to the Forum,

 

Someone else had a similar problem; I'll try to find it.

 

Are you sure you have the air con turned off ?

What temp is going up ?

The water temp; to a level much higher than usual ?

Hi air con is off water temp level normal o have narrowed it down to this part 

Screenshot_20220629-160501_Samsung Internet.jpg

Link to comment
Share on other sites

On 6/20/2022 at 7:45 PM, Alphard Club said:

 

@Mohammed imran

one point is that when it comes to boiling then you should add the cap back on or sooner.. you cannot leave cap off all the time, until you feel heat then you should be fine and its stopped burping itself. Just be careful.

Hi I have done this to no avail I have narrowed it down to this part as its not moving when changing temp from hot to cold but it's a nightmare getting to it 1419329721_Screenshot_20220629-160501_SamsungInternet.thumb.jpg.c70b5ede4bc176ac98d156368503b7e9.jpg

Link to comment
Share on other sites

On 6/20/2022 at 4:28 PM, Alphard Club said:

 

it really sounds like you have air in the Matrix. Thats why the temprature is half way because the water is still circulating but the air is trapped behind the dash. 

 

do the following

 

  1. let car go cold
  2. turn on engine
  3. whack temperature to hot .. full heat on the dash
  4. open up coolant cap on rad and bottle (do this when cold!!!)
  5. let the engine run to its temperature
  6. top up with coolant as needed as the engine will burp itself and the air will displace and will need a top up
  7. once the level stops dropping, top up and put cap on. Remember to do this part.

 

Very important you open up the heating on both front and back control panels this will allow the water to flow around both front and rear matrix.

No luck by doing this have narrowed it down to.this part

Screenshot_20220629-160501_Samsung Internet.jpg

Link to comment
Share on other sites

On 6/19/2022 at 10:48 PM, Mohammed imran said:

Hi can anyone help my alphard 3.0 has started blowing cold air from heaters I have just got a lpg conversion done few days ago yesterday I put heating on and it's only blowing cold air out Temp is going up on dash any body no  what it could be I got a feeling its this part 

 

Screenshot_20220629-160501_Samsung Internet.jpg

Link to comment
Share on other sites

9 minutes ago, Mohammed imran said:

No luck by doing this have narrowed it down to.this part

Screenshot_20220629-160501_Samsung Internet.jpg

 

Come to think of it, my actuator used to make noises on my ANH10 Alphard. So this could be the option too. But i do wonder if the rear heating is run from the same actuator??

Link to comment
Share on other sites

6 minutes ago, Alphard Club said:

 

Come to think of it, my actuator used to make noises on my ANH10 Alphard. So this could be the option too. But i do wonder if the rear heating is run from the same actuator??

Now that's something to consider did you get it replaced 

Link to comment
Share on other sites

Just now, Mohammed imran said:

Now that's something to consider did you get it replaced 

 

i still had heat, so left it, but unless i had it right down or all the way up it would make a juddering noise. 

I stuck my head underneath  centre consol and looked up to the heat controller to see it moving, so maybe you can try and see if you can see it moving if you adjust the temperature. But you see the rear ones may have their own... not sure, if the rear gets warm them it could be the front actuator.

Link to comment
Share on other sites

7 minutes ago, Alphard Club said:

 

i still had heat, so left it, but unless i had it right down or all the way up it would make a juddering noise. 

I stuck my head underneath  centre consol and looked up to the heat controller to see it moving, so maybe you can try and see if you can see it moving if you adjust the temperature. But you see the rear ones may have their own... not sure, if the rear gets warm them it could be the front actuator.

I thought of that but even rear is blowing cold air but then also the heat will come from front first then will get circulated to rear im looking for someone who can do this job for me now I will keep everyone informed not to bad at the moment as its the summer season 

Link to comment
Share on other sites

Speak to Stuart spencer autos in Birmingham ask for Phil great guy I bought my alphard off him and he does all his own repairs I'm sure he will help you he based in dudley so not really that far from you .

  • Like 1
Link to comment
Share on other sites

  • 3 months later...

Took my Alphard in to my usual repair shop with same problem. They tried all usual stuff and came to same conclusion. Heater flap actuator. They are struggling to find a replacement part. Second hand ones on internet seem to be different part number from the one on here. Anyone know of a dependable part supplier?

Link to comment
Share on other sites

I think you might find that this is the same part number for the same item that belongs to a Toyota Avensis 2003. Have you taken the old unit out of the Alphard yet, if you have it might be a good idea to open it up and check it out. The reason I say this is that it might just need the contacts cleaning. Hopefully this is of some help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.